The maintenance wont be completed in scheduled time. Still, the operation will continue until 29/05/2023 22:00 UTC to complete the upgrade.
Posted May 29, 2023 - 14:18 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2023 - 08:00 UTC
Scheduled
Start time : 29/05/2023 08:00 UTC End time : 29/05/2023 14:00 UTC Service impact : None Service improvement : We will enroll a version upgrade for Veeam Enterprise Europe.