Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2025 - 07:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 27, 2025 - 04:15 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Hosted Private Cloud offer.
Start time : 13/03/2025 07:30 UTC End time : 13/03/2025 09:30 UTC Service impact : You may experience micro cuts during maintenance. Service improvement : As part of our continuous improvement policy, we are rolling out an update for multiple servers.
Thank you for your understanding.
Posted Feb 27, 2025 - 04:14 UTC
This scheduled maintenance affected: Managed vSphere || RBX (Storage).