The current maintenance will take more time than expected to be completed. Below you can find the new end time.
End time : 25/05/2023 16:00 UTC
Posted May 25, 2023 - 13:47 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 25, 2023 - 10:01 UTC
Scheduled
Start time : 25/05/2023 10:00 UTC End time : 25/05/2023 14:00 UTC Service impact : None Service improvement : We will enroll a version upgrade for Veeam Enterprise Canada.